summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/strict-rfc3339/strict-rfc3339-0.7.ebuild')
-rw-r--r--dev-python/strict-rfc3339/strict-rfc3339-0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.7.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.7.ebuild
new file mode 100644
index 000000000000..50d9511f8aab
--- /dev/null
+++ b/dev-python/strict-rfc3339/strict-rfc3339-0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Strict, simple, lightweight RFC3339 functions"
+HOMEPAGE="https://pypi.python.org/pypi/strict-rfc3339 https://github.com/danielrichman/strict-rfc3339"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Not shipped
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_strict_rfc3339.py || die
+}