summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/test_server/test_server-0.0.31.ebuild')
-rw-r--r--dev-python/test_server/test_server-0.0.31.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/test_server/test_server-0.0.31.ebuild b/dev-python/test_server/test_server-0.0.31.ebuild
new file mode 100644
index 000000000000..37e2a350c72d
--- /dev/null
+++ b/dev-python/test_server/test_server-0.0.31.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Server to test HTTP clients"
+HOMEPAGE="https://github.com/lorien/test_server https://pypi.org/project/test-server/"
+SRC_URI="https://github.com/lorien/test_server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/bottle-0.12.13[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest