summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/testpath-0.5.0.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/testpath/testpath-0.5.0.ebuild b/dev-python/testpath/testpath-0.5.0.ebuild
index 44cf89905b50..dcda183aff88 100644
--- a/dev-python/testpath/testpath-0.5.0.ebuild
+++ b/dev-python/testpath/testpath-0.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -16,13 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
-BDEPEND="
- >=dev-python/pyproject2setuppy-15
- test? (
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+BDEPEND=">=dev-python/pyproject2setuppy-15"
distutils_enable_tests pytest
distutils_enable_sphinx doc