summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testrepository/testrepository-0.0.18-r2.ebuild')
-rw-r--r--dev-python/testrepository/testrepository-0.0.18-r2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.18-r2.ebuild b/dev-python/testrepository/testrepository-0.0.18-r2.ebuild
deleted file mode 100644
index 6cac0137838f..000000000000
--- a/dev-python/testrepository/testrepository-0.0.18-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A repository of test results"
-HOMEPAGE="https://launchpad.net/testscenarios"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]"
-#bzr is listed but presumably req'd for a live repo test run
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/testresources[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-# Required for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- # some errors appear to have crept in the suite undert py3 since addition.
- # Python2.7 now passes all.
-
- esetup.py testr --coverage
-}