summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/thunarx-python/thunarx-python-0.5.1.ebuild')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild
new file mode 100644
index 000000000000..cd7f101ea881
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/glib-2.30:2
+ >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}