summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/turbojson/turbojson-1.3.2-r1.ebuild')
-rw-r--r--dev-python/turbojson/turbojson-1.3.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/turbojson/turbojson-1.3.2-r1.ebuild b/dev-python/turbojson/turbojson-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..1613740b75c2
--- /dev/null
+++ b/dev-python/turbojson/turbojson-1.3.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="TurboJson"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TurboGears JSON file format support plugin"
+HOMEPAGE="http://pypi.python.org/pypi/TurboJson"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/simplejson-1.9.1[${PYTHON_USEDEP}]
+ >=dev-python/peak-rules-0.5[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+# Testsuite requires a package of peak not present in portage