summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-web/twisted-web-15.1.0.ebuild')
-rw-r--r--dev-python/twisted-web/twisted-web-15.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/twisted-web/twisted-web-15.1.0.ebuild b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
new file mode 100644
index 000000000000..039a4cbff409
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite