summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unittest2/files/unittest2-0.8.0-argparse.patch')
-rw-r--r--dev-python/unittest2/files/unittest2-0.8.0-argparse.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/unittest2/files/unittest2-0.8.0-argparse.patch b/dev-python/unittest2/files/unittest2-0.8.0-argparse.patch
new file mode 100644
index 000000000000..4435511c22f7
--- /dev/null
+++ b/dev-python/unittest2/files/unittest2-0.8.0-argparse.patch
@@ -0,0 +1,15 @@
+argparse is in standard library in Python 2.7 and >=3.2
+https://code.google.com/p/unittest-ext/issues/detail?id=88
+--- a/setup.py
++++ b/setup.py
+@@ -57,7 +57,9 @@
+ # Both install and setup requires - because we read VERSION from within the
+ # package, and the package also exports all the APIs.
+ # six for compat helpers
+-REQUIRES = ['argparse', 'six'],
++REQUIRES = ['six']
++if sys.version_info < (2, 7) or (3, 0) <= sys.version_info < (3, 2):
++ REQUIRES.append('argparse')
+
+ params = dict(
+ name=NAME,