summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webencodings/webencodings-0.5.ebuild')
-rw-r--r--dev-python/webencodings/webencodings-0.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/webencodings/webencodings-0.5.ebuild b/dev-python/webencodings/webencodings-0.5.ebuild
deleted file mode 100644
index b907e4c822c4..000000000000
--- a/dev-python/webencodings/webencodings-0.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Character encoding aliases for legacy web content"
-HOMEPAGE="https://github.com/SimonSapin/python-webencodings http://pypi.python.org/pypi/webencodings"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all(){
- cat >> setup.cfg <<- EOF
- [pytest]
- python_files=test*.py
- EOF
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v -v || die
-}