summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xdis/xdis-2.3.1.ebuild')
-rw-r--r--dev-python/xdis/xdis-2.3.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/xdis/xdis-2.3.1.ebuild b/dev-python/xdis/xdis-2.3.1.ebuild
deleted file mode 100644
index 73346d881de9..000000000000
--- a/dev-python/xdis/xdis-2.3.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
-HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Remove the 3.3 specific code from being run
- rm -R "test_unit/3.3" || die
- # Remove an unconditional test only dep
- sed \
- -e "s/setup_requires/tests_require/" \
- -i setup.py
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
- py.test -v || die "Tests failed under ${EPYTHON}"
- cd test
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- ${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \
- "Tests failed under ${EPYTHON}"
-}