summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-interface/zope-interface-5.1.2.ebuild')
-rw-r--r--dev-python/zope-interface/zope-interface-5.1.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/zope-interface/zope-interface-5.1.2.ebuild b/dev-python/zope-interface/zope-interface-5.1.2.ebuild
deleted file mode 100644
index 12cf5497347f..000000000000
--- a/dev-python/zope-interface/zope-interface-5.1.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# pkg_resources namespace
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Interfaces for Python"
-HOMEPAGE="https://pypi.org/project/zope.interface/ https://github.com/zopefoundation/zope.interface"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/zope-event[${PYTHON_USEDEP}]
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/5.1.0-drop-coverage.patch
-)
-
-distutils_enable_tests setup.py
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}