summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild b/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
index 5eb8bbd6f85b..e4d0ca64c36a 100644
--- a/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
+++ b/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{7..10} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -15,11 +15,5 @@ SRC_URI="https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests || die
-}
+distutils_enable_tests nose