summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.25.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index cdb9638d8c4c..3603e1f14b2f 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,2 @@
DIST configshell-fb-1.1.24.tar.gz 56946 BLAKE2B ddda3313bb41a346d08006f1d3c1cdc708a940ab9fb2e0042896947b89e32cca872fc8a19a392eeebbc6403f042aadcef2c78962c069e9c1ed10a2f5d4bb102f SHA512 34aabe6fa5c2f00112748e35fe3859fae09baac5ef13b9aa80e6f00908290a0d724119aa3b2ce86da8bb171c60860304e650aeb16bc678354a7464bd0b5c9b48
+DIST configshell-fb-1.1.25.tar.gz 56900 BLAKE2B 00f16c401a87cde0e70730ec74fe5885af3ebf22c3745851661fea7de874f5609c49e0b7c521c5d3db16eec903e0f24331816acc8e19a080043e8399c98bd18f SHA512 338eee8eb7b0fad533b739bb0c9460757cdb90103c44c37568dd86158431b67e1b0ab050afe2670abbba96c5d8c18db9b107d9f7650937a2be7f53fad26efed3
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.25.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.25.ebuild
new file mode 100644
index 000000000000..4fe6f47f5099
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.25.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"