summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rdflib/Manifest3
-rw-r--r--dev-python/rdflib/files/rdflib-4-test.patch41
-rw-r--r--dev-python/rdflib/rdflib-3.2.3-r1.ebuild45
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild61
-rw-r--r--dev-python/rdflib/rdflib-4.2.0.ebuild62
5 files changed, 0 insertions, 212 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index dd258bd60808..cdb4182e954a 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1,4 +1 @@
-DIST rdflib-3.2.3.tar.gz 449077 SHA256 a3cab51c14fa6fe379261e0157c110d94e2f75ef62073ddc76fe56f5be624b75 SHA512 92697be6d6bba4e31303b46c2a42defd840770f75c6f359b7338fa3d48a2001cdcda3b6319403ad0c9f1696051d773b146c9b012770df81b4d94a34d30f6b02a WHIRLPOOL b41794febee280022990dac8c4e177660f69803f01fc14ade194015bc6cf1eaf23164620b09cf1123445d181c0bbe9f0733b901cddafb126bcd711d0462a9f7b
-DIST rdflib-4.1.2.tar.gz 868883 SHA256 3cf94bda0867f21468b248ce9f671581efb92ae9edd28ff321716126c6706a4f SHA512 99d4a4b4d37808563575ac13312cf0e0975f7c1563117cfe7e4b70a84a2804f7eb57144d6a7c629c109ff7b236a6ea2489a4925ae41791274f3b234143837e65 WHIRLPOOL 090e00cc3113cec158f786a39103450f0d1d25571ad57c346120756901f01b0fcf20ff731ae3b174b54f3621e46a26061eee7bd774ffdf91380f4a3647380590
-DIST rdflib-4.2.0.tar.gz 881424 SHA256 7420dafc4930249d0cfcf31e8547a39b658d079ab2c9e975465f6697a8476ec0 SHA512 7677869eb0a65ede317634253042da68b4e183d5352cd37bd949380eb29deec8329336067a2ab686c90d6a1718f8e7a9039424753846d879cce41c05f656735f WHIRLPOOL 62f67318ade0fee1d5d64d6294aa821f4f06f940b18e421d43292e749e495cb3e348b522dd79eec805ce88125d8a6864dccc4a4037ed0a52d5aed616e51b39f5
DIST rdflib-4.2.1.tar.gz 889467 SHA256 eb02bd235606ef3b26e213da3e576557a6392ce103efd8c6c8ff1e08321608c8 SHA512 49145f80a9e027847523faed059c16ec1de358bb9d8fc3ab4fd3bf95a88dd181986b1785deedf6e837cf0b064bd74ab8e27fbb5581e33310353da3546ae7b016 WHIRLPOOL 010bb4cf7c544b9a3f28636182b6c1821f390066bfe3de59f58fb7cfd8d809d8b0b5f256134b9c5091327c7ba6319be02135d6ea8a6d8b37772e212f000c3ba7
diff --git a/dev-python/rdflib/files/rdflib-4-test.patch b/dev-python/rdflib/files/rdflib-4-test.patch
deleted file mode 100644
index e79e3ff2a6eb..000000000000
--- a/dev-python/rdflib/files/rdflib-4-test.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-https://github.com/joernhees/rdflib/commit/36335d5d178ffbcc0422b8b8ee7444893a30ed84
-diff --git a/test/test_issue375.py b/test/test_issue375.py
-index 29726b9..17f168b 100644
---- a/test/test_issue375.py
-+++ b/test/test_issue375.py
-@@ -1,4 +1,6 @@
-+import os
- import subprocess
-+import sys
- import re
-
- rdfa_expected = u'''@prefix dc: <http://purl.org/dc/terms/> .
-@@ -146,6 +148,9 @@
- rdfa:usesVocabulary schema: .
- '''.strip()
-
-+env = os.environ.copy()
-+env['PYTHONPATH'] = '.:' + env.get('PYTHONPATH', '')
-+
- def test_rdfpipe_bytes_vs_str():
- """
- Issue 375: rdfpipe command generates bytes vs. str TypeError
-@@ -155,7 +160,7 @@ def test_rdfpipe_bytes_vs_str():
- rdfpipe to ensure that we get the expected results.
- """
- args = ['python', 'rdflib/tools/rdfpipe.py', '-i', 'rdfa1.1', 'test/rdfa/oreilly.html']
-- proc = subprocess.Popen(args, stdout=subprocess.PIPE, universal_newlines=True)
-+ proc = subprocess.Popen(args, stdout=subprocess.PIPE, universal_newlines=True, env=env)
- res = ''
- while proc.poll() is None:
- res += proc.stdout.read()
-@@ -170,7 +175,7 @@ def test_rdfpipe_mdata_open():
- the open() builtin instead.
- """
- args = ['python', 'rdflib/tools/rdfpipe.py', '-i', 'mdata', 'test/mdata/codelab.html']
-- proc = subprocess.Popen(args, stdout=subprocess.PIPE, universal_newlines=True)
-+ proc = subprocess.Popen(args, stdout=subprocess.PIPE, universal_newlines=True, env=env)
- res = ''
- while proc.poll() is None:
- res += proc.stdout.read()
-
diff --git a/dev-python/rdflib/rdflib-3.2.3-r1.ebuild b/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
deleted file mode 100644
index a3a4060d57da..000000000000
--- a/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3 )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 --py3where='build/src' || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
deleted file mode 100644
index ec9dee1cfc30..000000000000
--- a/dev-python/rdflib/rdflib-4.1.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-# The usual required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[$(python_gen_usedep 'python2*')]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep 'python2*')] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-4-test.patch )
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
-
- # Bug 358189; take out tests that attempt to connect to the network
- sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
- -e "/'--doctest-tests',/d" -i run_tests.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # the default; nose with: --where=./ does not work for python3
- if python_is_python3; then
- pushd "${BUILD_DIR}/src/" > /dev/null
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- popd > /dev/null
- else
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/rdflib/rdflib-4.2.0.ebuild b/dev-python/rdflib/rdflib-4.2.0.ebuild
deleted file mode 100644
index 3f2df3fe9b49..000000000000
--- a/dev-python/rdflib/rdflib-4.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-
-# The usual required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep python2_7)] )
- redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep python2_7)] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-4-test.patch )
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
-
- # Bug 358189; take out tests that attempt to connect to the network
- sed -e "/'--with-doctest',/d" -e "/'--doctest-extension=.doctest',/d" \
- -e "/'--doctest-tests',/d" -i run_tests.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # the default; nose with: --where=./ does not work for python3
- if python_is_python3; then
- pushd "${BUILD_DIR}/src/" > /dev/null
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- popd > /dev/null
- else
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}