summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtscript/qtscript-4.8.7.ebuild')
-rw-r--r--dev-qt/qtscript/qtscript-4.8.7.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-qt/qtscript/qtscript-4.8.7.ebuild b/dev-qt/qtscript/qtscript-4.8.7.ebuild
deleted file mode 100644
index ce3c8d0893c2..000000000000
--- a/dev-qt/qtscript/qtscript-4.8.7.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit qt4-build-multilib
-
-DESCRIPTION="The QtScript module for the Qt toolkit"
-
-if [[ ${QT4_BUILD_TYPE} == release ]]; then
- KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
-fi
-
-IUSE="+jit"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-QT4_TARGET_DIRECTORIES="src/script"
-
-QCONFIG_ADD="script"
-QCONFIG_DEFINE="QT_SCRIPT"
-
-PATCHES=( "${FILESDIR}/4.8.6-javascriptcore-x32.patch" )
-
-multilib_src_configure() {
- local myconf=(
- $(qt_use jit javascript-jit)
- -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
- -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
- -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
- -no-gtkstyle
- )
- qt4_multilib_src_configure
-}