summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtvirtualkeyboard')
-rw-r--r--dev-qt/qtvirtualkeyboard/Manifest4
-rw-r--r--dev-qt/qtvirtualkeyboard/metadata.xml3
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.13.ebuild (renamed from dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.2.ebuild)29
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild51
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild51
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild51
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild51
7 files changed, 223 insertions, 17 deletions
diff --git a/dev-qt/qtvirtualkeyboard/Manifest b/dev-qt/qtvirtualkeyboard/Manifest
index 963bafeb15dd..8e25ec29244b 100644
--- a/dev-qt/qtvirtualkeyboard/Manifest
+++ b/dev-qt/qtvirtualkeyboard/Manifest
@@ -1 +1,3 @@
-DIST qtvirtualkeyboard-everywhere-src-5.15.2.tar.xz 10955076 BLAKE2B 629068b92f58e825060410c84906edbcb9d83f942f1d4acfc1aab9404eb69e0ffeca0b5ca69a3d4b07033efb80ef161f23474e0a19ae6d9c4efb7698ba0a0d75 SHA512 3ba04d171756a5434424833c5198a23e0df53eeebe9ea542047e094f83f38492d93f901cac67cf7e55aca6a71289ce3c6f5d8ac10a8d051b291155ebb8432016
+DIST qtvirtualkeyboard-everywhere-opensource-src-5.15.13.tar.xz 10959164 BLAKE2B 808c5f28f12d0210b94ee3c9f282c000c1787686e454c8cb8ef601dafe7c0d8579796b2322edb553a997d4a8f38c2603b5314f6839873b257930bd9aa3959222 SHA512 abe58c132c8bd23d29de1937e2f1fb6571aec829ce74f4904d322c4046d8c70b4b9b508930e4c681a8e30ff1d8a63c627cc3bec1560e83dada426c09d827ae29
+DIST qtvirtualkeyboard-everywhere-src-6.7.0.tar.xz 3720012 BLAKE2B 5bb60703f88225e8d2b18323c394b3f863a2364c39023eacf33c49d9ab3e0f0966f1ff37a38dd44ef3497d5f446a25aba7731697fd572fa001258657af54b7a8 SHA512 0e33a9d962eed6a75bceb25ba666adff2ee0e3eea229540415777000fd60de290c4b56a07870239943e96da626d71e4e4770d46198b8bfe1fb5e03bee64740e9
+DIST qtvirtualkeyboard-everywhere-src-6.7.1.tar.xz 3729484 BLAKE2B d5079f63f8c8dac1d5f364c7fc92477eb50f05c991ce9fbd2f5c7cde424348f9284b18b39bb0a22962aac5bdefdd890650356d65653ab20c68ab98b779e2a1cc SHA512 7d3baf735cac2906de5bc982fc3d1efa45c77d1d527ca3392cade59975cc8307ea85b0f7f018607cfc531742e8da6bfbc04f9ba4b523b2ebf1ebcde8f64befcd
diff --git a/dev-qt/qtvirtualkeyboard/metadata.xml b/dev-qt/qtvirtualkeyboard/metadata.xml
index 1f6a41cfea6b..e84bfa0f97be 100644
--- a/dev-qt/qtvirtualkeyboard/metadata.xml
+++ b/dev-qt/qtvirtualkeyboard/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>qt@gentoo.org</email>
@@ -11,6 +11,7 @@
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
<doc>https://doc.qt.io/</doc>
+ <remote-id type="github">qt/qtvirtualkeyboard</remote-id>
</upstream>
<slots>
<subslots>
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.2.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.13.ebuild
index db9bfdfb2ad0..4980321fc38e 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.2.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-5.15.13.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+fi
inherit qt5-build
DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-fi
-
-# TODO: unbudle libraries for more layouts
+# TODO: unbundle libraries for more layouts
IUSE="handwriting +spell +X"
DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qtsvg-${PV}
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtsvg-${QT5_PV}*
spell? ( app-text/hunspell:= )
X? ( x11-libs/libxcb:= )
"
@@ -26,9 +26,9 @@ RDEPEND="${DEPEND}"
src_configure() {
local myqmakeargs=(
- $(usex handwriting CONFIG+=lipi-toolkit '')
- $(usex spell '' CONFIG+=disable-hunspell)
- $(usex X '' CONFIG+=disable-desktop)
+ $(usev handwriting CONFIG+=lipi-toolkit)
+ $(usev !spell CONFIG+=disable-hunspell)
+ $(usev !X CONFIG+=disable-desktop)
CONFIG+="lang-ar_AR lang-bg_BG lang-cs_CZ lang-da_DK lang-de_DE \
lang-el_GR lang-en_GB lang-en_US lang-es_ES lang-es_MX \
lang-et_EE lang-fa_FA lang-fi_FI lang-fr_CA lang-fr_FR \
@@ -38,6 +38,5 @@ src_configure() {
lang-sl_SI lang-sq_AL lang-sr_SP lang-sv_SE lang-tr_TR \
lang-uk_UA lang-vi_VN"
)
-
qt5-build_src_configure
}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild
new file mode 100644
index 000000000000..4c15bd6a2a04
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild
new file mode 100644
index 000000000000..a6537989835b
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
new file mode 100644
index 000000000000..a6537989835b
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
new file mode 100644
index 000000000000..a6537989835b
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}