summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0-r1.ebuild')
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0-r1.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0-r1.ebuild
new file mode 100644
index 000000000000..ee76a3e1f2b2
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ )
+"
+PATCHES=( "${FILESDIR}/ocv_leak.patch" )