summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cpp_common/cpp_common-0.6.1.ebuild')
-rw-r--r--dev-ros/cpp_common/cpp_common-0.6.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/cpp_common/cpp_common-0.6.1.ebuild b/dev-ros/cpp_common/cpp_common-0.6.1.ebuild
new file mode 100644
index 000000000000..616d2d7a20ba
--- /dev/null
+++ b/dev-ros/cpp_common/cpp_common-0.6.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ code for doing things that are not necessarily ROS related"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge
+ dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"