summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/cv_bridge/cv_bridge-1.12.1.ebuild')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.12.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-1.12.1.ebuild b/dev-ros/cv_bridge/cv_bridge-1.12.1.ebuild
new file mode 100644
index 000000000000..52147ea815de
--- /dev/null
+++ b/dev-ros/cv_bridge/cv_bridge-1.12.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ media-libs/opencv[contrib(+)]
+ dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"