summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genmsg/genmsg-0.5.6.ebuild')
-rw-r--r--dev-ros/genmsg/genmsg-0.5.6.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/genmsg/genmsg-0.5.6.ebuild b/dev-ros/genmsg/genmsg-0.5.6.ebuild
new file mode 100644
index 000000000000..d70c53c0941d
--- /dev/null
+++ b/dev-ros/genmsg/genmsg-0.5.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/genmsg"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python library for generating ROS message and service data structures for various languages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"