summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild')
-rw-r--r--dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild
new file mode 100644
index 000000000000..8c5f1556370f
--- /dev/null
+++ b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Means for transporting compressed map data through the use of image_transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/hector_map_tools
+ dev-ros/image_transport
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"