summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/mavros_msgs/mavros_msgs-0.16.3.ebuild')
-rw-r--r--dev-ros/mavros_msgs/mavros_msgs-0.16.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/mavros_msgs/mavros_msgs-0.16.3.ebuild b/dev-ros/mavros_msgs/mavros_msgs-0.16.3.ebuild
new file mode 100644
index 000000000000..7c9f450664e1
--- /dev/null
+++ b/dev-ros/mavros_msgs/mavros_msgs-0.16.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for MAVROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"