summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosbridge_server/rosbridge_server-0.8.3.ebuild')
-rw-r--r--dev-ros/rosbridge_server/rosbridge_server-0.8.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rosbridge_server/rosbridge_server-0.8.3.ebuild b/dev-ros/rosbridge_server/rosbridge_server-0.8.3.ebuild
new file mode 100644
index 000000000000..775590dc7d3b
--- /dev/null
+++ b/dev-ros/rosbridge_server/rosbridge_server-0.8.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A WebSocket interface to rosbridge"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosauth[${PYTHON_USEDEP}]
+ dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/backports-ssl.patch"
+ "${FILESDIR}/tornado.patch"
+)