summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.0.ebuild')
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.0.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.0.ebuild
new file mode 100644
index 000000000000..393ca54867e1
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"