summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.11.16.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.11.16.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.11.16.ebuild b/dev-ros/rosmaster/rosmaster-1.11.16.ebuild
new file mode 100644
index 000000000000..ec8fb4f31a65
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.11.16.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"