summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rostime/rostime-0.6.4.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.6.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.6.4.ebuild b/dev-ros/rostime/rostime-0.6.4.ebuild
new file mode 100644
index 000000000000..ccd863194982
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.6.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"