summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/shape_tools/shape_tools-9999.ebuild')
-rw-r--r--dev-ros/shape_tools/shape_tools-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/shape_tools/shape_tools-9999.ebuild b/dev-ros/shape_tools/shape_tools-9999.ebuild
new file mode 100644
index 000000000000..55a402976188
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}