summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/smach_ros/smach_ros-2.0.1.ebuild')
-rw-r--r--dev-ros/smach_ros/smach_ros-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/smach_ros-2.0.1.ebuild b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
new file mode 100644
index 000000000000..d3df8eeab34e
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"