summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-9999.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-9999.ebuild b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
index 39bfc4bf09a4..6162bbe7696c 100644
--- a/dev-ros/test_roscpp/test_roscpp-9999.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
@@ -32,5 +32,7 @@ PATCHES=( "${FILESDIR}/tests.patch" )
src_test() {
export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
+ # Sometimes high number of tests running in parallel make them fail
+ # https://bugs.gentoo.org/738620
+ ros-catkin_src_test -j 1
}