summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_tf2')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.7.2.ebuild10
-rw-r--r--dev-ros/test_tf2/test_tf2-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.7.2.ebuild b/dev-ros/test_tf2/test_tf2-0.7.2.ebuild
index c69d1b425fba..10d0f26755b0 100644
--- a/dev-ros/test_tf2/test_tf2-0.7.2.ebuild
+++ b/dev-ros/test_tf2/test_tf2-0.7.2.ebuild
@@ -17,16 +17,16 @@ RDEPEND=""
DEPEND="
dev-ros/rosconsole
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf
dev-ros/tf2
dev-ros/tf2_bullet
- dev-ros/tf2_ros[${PYTHON_USEDEP}]
- dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
- dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf2_msgs
sci-libs/orocos_kdl
- dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
dev-libs/boost:=[threads]
dev-cpp/gtest"
diff --git a/dev-ros/test_tf2/test_tf2-9999.ebuild b/dev-ros/test_tf2/test_tf2-9999.ebuild
index c69d1b425fba..10d0f26755b0 100644
--- a/dev-ros/test_tf2/test_tf2-9999.ebuild
+++ b/dev-ros/test_tf2/test_tf2-9999.ebuild
@@ -17,16 +17,16 @@ RDEPEND=""
DEPEND="
dev-ros/rosconsole
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf
dev-ros/tf2
dev-ros/tf2_bullet
- dev-ros/tf2_ros[${PYTHON_USEDEP}]
- dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
- dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf2_msgs
sci-libs/orocos_kdl
- dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
dev-libs/boost:=[threads]
dev-cpp/gtest"