summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/visp_tracker/visp_tracker-0.8.0.ebuild')
-rw-r--r--dev-ros/visp_tracker/visp_tracker-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/visp_tracker/visp_tracker-0.8.0.ebuild b/dev-ros/visp_tracker/visp_tracker-0.8.0.ebuild
new file mode 100644
index 000000000000..a328763e73bf
--- /dev/null
+++ b/dev-ros/visp_tracker/visp_tracker-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Wraps the ViSP moving edge tracker provided by the ViSP visual servoing library into a ROS package"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/dynamic_reconfigure
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/image_proc
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/resource_retriever
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/ViSP
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi