summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_proc/files/ocv_leak.patch13
-rw-r--r--dev-ros/image_proc/image_proc-1.15.2-r1.ebuild (renamed from dev-ros/image_proc/image_proc-1.15.2.ebuild)1
-rw-r--r--dev-ros/image_proc/image_proc-9999.ebuild1
3 files changed, 15 insertions, 0 deletions
diff --git a/dev-ros/image_proc/files/ocv_leak.patch b/dev-ros/image_proc/files/ocv_leak.patch
new file mode 100644
index 000000000000..79722625d327
--- /dev/null
+++ b/dev-ros/image_proc/files/ocv_leak.patch
@@ -0,0 +1,13 @@
+Index: image_proc/CMakeLists.txt
+===================================================================
+--- image_proc.orig/CMakeLists.txt
++++ image_proc/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(image_proc)
+ find_package(catkin REQUIRED)
+
+ find_package(catkin REQUIRED cv_bridge dynamic_reconfigure image_geometry image_transport nodelet nodelet_topic_tools roscpp sensor_msgs)
+-find_package(OpenCV REQUIRED)
++find_package(OpenCV REQUIRED COMPONENTS opencv_core opencv_imgproc opencv_highgui)
+ find_package(Boost REQUIRED COMPONENTS thread)
+
+ if(cv_bridge_VERSION VERSION_GREATER "1.12.0")
diff --git a/dev-ros/image_proc/image_proc-1.15.2.ebuild b/dev-ros/image_proc/image_proc-1.15.2-r1.ebuild
index e38214ace5bb..ee3903c63127 100644
--- a/dev-ros/image_proc/image_proc-1.15.2.ebuild
+++ b/dev-ros/image_proc/image_proc-1.15.2-r1.ebuild
@@ -33,3 +33,4 @@ DEPEND="${RDEPEND}
dev-ros/camera_calibration_parsers
)
"
+PATCHES=( "${FILESDIR}/ocv_leak.patch" )
diff --git a/dev-ros/image_proc/image_proc-9999.ebuild b/dev-ros/image_proc/image_proc-9999.ebuild
index e38214ace5bb..ee3903c63127 100644
--- a/dev-ros/image_proc/image_proc-9999.ebuild
+++ b/dev-ros/image_proc/image_proc-9999.ebuild
@@ -33,3 +33,4 @@ DEPEND="${RDEPEND}
dev-ros/camera_calibration_parsers
)
"
+PATCHES=( "${FILESDIR}/ocv_leak.patch" )