summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/audio_capture/Manifest1
-rw-r--r--dev-ros/audio_capture/audio_capture-0.2.7.ebuild29
-rw-r--r--dev-ros/audio_capture/audio_capture-9999.ebuild29
-rw-r--r--dev-ros/audio_capture/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/audio_capture/Manifest b/dev-ros/audio_capture/Manifest
new file mode 100644
index 000000000000..aec3da0b587f
--- /dev/null
+++ b/dev-ros/audio_capture/Manifest
@@ -0,0 +1 @@
+DIST audio_common-0.2.7.tar.gz 173982 SHA256 bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4 SHA512 f765422bdb641e87132e1c9c56ca742d6830fed1d7414b337b61aa242f9955e4138ab13ee4a7786c78ff73f5824748ceb38f98612a7f12dab4dcdc97efa289e3 WHIRLPOOL d1bf17f8bd0e8346d2fff48982c402b0eaa2ea4365b3195e3dd0c4943c93cf1935fdff85a0d2018e43e5074640692c3d72dc72887c86d955dc02c60800e3725b
diff --git a/dev-ros/audio_capture/audio_capture-0.2.7.ebuild b/dev-ros/audio_capture/audio_capture-0.2.7.ebuild
new file mode 100644
index 000000000000..dd65eace76e5
--- /dev/null
+++ b/dev-ros/audio_capture/audio_capture-0.2.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transports audio from a source to a destination"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:0.10
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-plugins/gst-plugins-lame:0.10
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"
diff --git a/dev-ros/audio_capture/audio_capture-9999.ebuild b/dev-ros/audio_capture/audio_capture-9999.ebuild
new file mode 100644
index 000000000000..dd65eace76e5
--- /dev/null
+++ b/dev-ros/audio_capture/audio_capture-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transports audio from a source to a destination"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:0.10
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-plugins/gst-plugins-lame:0.10
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"
diff --git a/dev-ros/audio_capture/metadata.xml b/dev-ros/audio_capture/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/audio_capture/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>