summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/RubyInline/RubyInline-3.12.2.ebuild')
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild
deleted file mode 100644
index d47c154c16fe..000000000000
--- a/dev-ruby/RubyInline/RubyInline-3.12.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows to embed C/C++ in Ruby code"
-HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend dev-ruby/zentest
-
-ruby_add_bdepend "
- test? (
- dev-ruby/hoe
- dev-ruby/hoe-seattlerb
- virtual/ruby-minitest
- )"
-
-RUBY_PATCHES=(
- ruby-inline-3.12.2-gentoo.patch
- ruby-inline-3.11.1-ldflags.patch
-)
-
-all_ruby_prepare() {
- sed -i -e '/isolate/ s:^:#:' Rakefile || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc example.rb example2.rb demo/*.rb
-}