summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionpack/actionpack-5.0.3.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-5.0.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ruby/actionpack/actionpack-5.0.3.ebuild b/dev-ruby/actionpack/actionpack-5.0.3.ebuild
deleted file mode 100644
index 54a7040729c5..000000000000
--- a/dev-ruby/actionpack/actionpack-5.0.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- dev-ruby/rack:2.0
- >=dev-ruby/rack-test-0.6.3:0.6
- >=dev-ruby/rails-html-sanitizer-1.0.2:1
- dev-ruby/rails-dom-testing:2
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/rack-cache-1.2:1.2
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- rm ../Gemfile.lock || die
-
- # Skip a failing test related to security updates in 4.2.5.1. Let's
- # assume that this is not a bug but a test lagging a security
- # measure.
- sed -i -e '/test_dynamic_render_with_file/,/^ end/ s:^:#:' \
- test/controller/render_test.rb || die
-
- # Skip brittle test depending on mime type registration order (fixed upstream)
- sed -i -e '/parse application with trailing star/,/^ end/ s:^:#:' \
- test/dispatch/mime_type_test.rb
-}