summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activesupport/activesupport-6.1.7.4.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.7.4.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/activesupport/activesupport-6.1.7.4.ebuild b/dev-ruby/activesupport/activesupport-6.1.7.4.ebuild
index 1102563d0826..22d4ef1e0ab4 100644
--- a/dev-ruby/activesupport/activesupport-6.1.7.4.ebuild
+++ b/dev-ruby/activesupport/activesupport-6.1.7.4.ebuild
@@ -65,8 +65,10 @@ all_ruby_prepare() {
rm ../Gemfile.lock || die
# sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
- # Avoid test that depends on timezone
- sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+ # Avoid test that depends on timezone and test that fails on 32-bit arches
+ sed -e '/test_implicit_coercion/,/^ end/ s:^:#:' \
+ -e '/test_iso8601_output_and_reparsing/askip "Broken on 32-bit arches"' \
+ -i test/core_ext/duration_test.rb || die
# Avoid tests that seem to trigger race conditions.
rm -f test/evented_file_update_checker_test.rb || die