summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/amatch/amatch-0.3.0.ebuild')
-rw-r--r--dev-ruby/amatch/amatch-0.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/amatch/amatch-0.3.0.ebuild b/dev-ruby/amatch/amatch-0.3.0.ebuild
new file mode 100644
index 000000000000..14cf09a4e747
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="http://flori.github.com/amatch/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.3"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/amatch_ext$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/* || die
+}