summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/atomic/atomic-1.1.99.ebuild')
-rw-r--r--dev-ruby/atomic/atomic-1.1.99.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/atomic/atomic-1.1.99.ebuild b/dev-ruby/atomic/atomic-1.1.99.ebuild
deleted file mode 100644
index b70c62957f02..000000000000
--- a/dev-ruby/atomic/atomic-1.1.99.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
-HOMEPAGE="https://github.com/headius/ruby-atomic"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ~ppc64 x86"
-IUSE=""
-
-all_ruby_prepare() {
- # Avoid compilation dependencies since we compile directly.
- sed -i -e '/:test => :compile/ s:^:#:' \
- -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/atomic_reference$(get_modname) lib/ || die
-}