summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild')
-rw-r--r--dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild b/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild
new file mode 100644
index 000000000000..2ae9f576ab1e
--- /dev/null
+++ b/dev-ruby/bundler-audit/bundler-audit-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides patch-level verification for Bundled apps"
+HOMEPAGE="https://github.com/rubysec/bundler-audit"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/thor-0.18:0
+ >=dev-ruby/bundler-1.2:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that require network access via 'bundle install'
+ rm spec/{integration,scanner}_spec.rb || die
+
+ # Avoid specs that only work when the source is a git repository
+ sed -i -e '/describe "path"/,/^ end/ s:^:#:' \
+ -e '/describe "update!"/,/^ end/ s:^:#:' \
+ spec/database_spec.rb || die
+}