summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/classifier/classifier-1.3.4.ebuild')
-rw-r--r--dev-ruby/classifier/classifier-1.3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/classifier/classifier-1.3.4.ebuild b/dev-ruby/classifier/classifier-1.3.4.ebuild
new file mode 100644
index 000000000000..58ee5eba199a
--- /dev/null
+++ b/dev-ruby/classifier/classifier-1.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="http://rubyforge.org/projects/classifier https://github.com/cardmagic/classifier"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier-reborn
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "s/PKG_VERSION/\"${PV}\"/" \
+ -e "s#PKG_FILES#FileList[ \"lib/**/*\", \"bin/*\", \"test/**/*\", \"[A-Z]*\", \"Rakefile\", \"Gemfile\", \"html/**/*\"]#" Rakefile
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/' -i lib/${PN}/lsi.rb || die
+ rm test/lsi/lsi_test.rb || die
+ fi
+ # Remove failing test for now
+ rm test/extensions/word_hash_test.rb || die
+}