summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/compass-import-once')
-rw-r--r--dev-ruby/compass-import-once/Manifest1
-rw-r--r--dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild33
-rw-r--r--dev-ruby/compass-import-once/metadata.xml13
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/compass-import-once/Manifest b/dev-ruby/compass-import-once/Manifest
new file mode 100644
index 000000000000..90012fbbda98
--- /dev/null
+++ b/dev-ruby/compass-import-once/Manifest
@@ -0,0 +1 @@
+DIST compass-import-once-1.0.5.gem 9728 SHA256 38978ffed0d332e8526e87e1befd1b6831774ca7d8350c5adb5b9eef167fc72e SHA512 2ef723803341892b34a4bbe691b32ddd266a125c5e3faf8034c473566d70c7a8c0931f1a02abe64c243fe62f2a204cc8e53b951dd88c440eada4ec2dfc19856b WHIRLPOOL 70804304882031ea8d12a8fcfa56687e77a594e3b86235a56157218306dc9898a64c9a79279fcdd0225ff439fdf3912ae7f3e7100c963fcbf981eacca5bdc3a9
diff --git a/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild b/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
new file mode 100644
index 000000000000..df9431987b39
--- /dev/null
+++ b/dev-ruby/compass-import-once/compass-import-once-1.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Skip tests since they depend on sass-globbing which does not have a
+# license and where the last version is known to be broken.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Speed up your Sass compilation by making @import only import each file once"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/sass-3.2 <dev-ruby/sass-3.5
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/compass-import-once/metadata.xml b/dev-ruby/compass-import-once/metadata.xml
new file mode 100644
index 000000000000..ba11df1021de
--- /dev/null
+++ b/dev-ruby/compass-import-once/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury (vikraman)</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compass is a Sass-based Stylesheet Framework that streamlines the
+ creation and maintenance of CSS.
+ </longdescription>
+</pkgmetadata>