summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/diva')
-rw-r--r--dev-ruby/diva/Manifest4
-rw-r--r--dev-ruby/diva/diva-0.3.2.ebuild25
-rw-r--r--dev-ruby/diva/diva-1.0.0.ebuild24
-rw-r--r--dev-ruby/diva/diva-1.1.1-r1.ebuild33
-rw-r--r--dev-ruby/diva/diva-2.0.1.ebuild33
-rw-r--r--dev-ruby/diva/metadata.xml4
6 files changed, 71 insertions, 52 deletions
diff --git a/dev-ruby/diva/Manifest b/dev-ruby/diva/Manifest
index ee15068b08ec..f68ce0cef242 100644
--- a/dev-ruby/diva/Manifest
+++ b/dev-ruby/diva/Manifest
@@ -1,2 +1,2 @@
-DIST diva-0.3.2.gem 13824 BLAKE2B da6236bf24dfca3d2ebc241172ee104c5ce66001446fcef397108695ffa70e37d65de9a2db29a706f6f81c5d6a70934cc59155d94e890f7499ed572df3adecdd SHA512 3506aead4314d8d43c838ca0bc596a8f63e6d0b86da68810999e9101bfad611b8fd4902078ec7495e66704e756d928ec28e916105f22c4260b2681ab97eb08aa
-DIST diva-1.0.0.tar.gz 13654 BLAKE2B 3743a2a0cacf6390a2bb2149e1213c9057c7c348fdb514d622b1edeeaad52a8a255defa0ea556a6bc5f89889d36f9f096b63d48eb03d868797f37ba2a5ba6a03 SHA512 d29375840893f61f022e3afb041855486ff13266a9635c8d944177df0642f1e53c0038b5bd6fecfa2d02296558f6f0f0e4f86089434f6c5f04a440044c9b75ca
+DIST diva-1.1.1.tar.gz 15974 BLAKE2B 2a3b497181a931eb6cf6c43b9d43ff9e0e7a34a753864bec422b69c6d01aa39b5f9dcc6abd54b85ca27b34d38a647c3e80450c2d7dd9cea1c62859eb3366d28d SHA512 36c7048cba2774567191b40ff88fa7804b61cb9334992dadd43a62f18be6635aa48753593ccba93a7c0438adfb7d75266b26b7a62e102aaf99afff7401c4e99a
+DIST diva-2.0.1.tar.gz 16964 BLAKE2B 768f9fa670db229db424a069adcfa4706c2b9969d143cffbbaeeafc9b1a2eeaa6b4a1c53de90206a4625f65f89a2c478957c3b53a21eb00f89a470e6071a6d57 SHA512 248f2b9770bd8d097fdfd7edfd574358d3e47c907d8c7e15b6e4b9cc5b72e9b7b428bac211e4d5a4e516c206afb82ecb069103c85835a1c65ed646e68e4a0a6e
diff --git a/dev-ruby/diva/diva-0.3.2.ebuild b/dev-ruby/diva/diva-0.3.2.ebuild
deleted file mode 100644
index eecba531b5e5..000000000000
--- a/dev-ruby/diva/diva-0.3.2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implementation of expression for handling things."
-HOMEPAGE="https://rubygems.org/gems/diva"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "<dev-ruby/addressable-2.6"
diff --git a/dev-ruby/diva/diva-1.0.0.ebuild b/dev-ruby/diva/diva-1.0.0.ebuild
deleted file mode 100644
index 2023272a0fae..000000000000
--- a/dev-ruby/diva/diva-1.0.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implementation of expression for handling things."
-HOMEPAGE="https://github.com/toshia/diva"
-SRC_URI="https://github.com/toshia/diva/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "<dev-ruby/addressable-2.7"
diff --git a/dev-ruby/diva/diva-1.1.1-r1.ebuild b/dev-ruby/diva/diva-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..2ac67e714eb7
--- /dev/null
+++ b/dev-ruby/diva/diva-1.1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="diva.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of expression for handling things"
+HOMEPAGE="https://github.com/toshia/diva https://rubygems.org/gems/diva"
+SRC_URI="https://github.com/toshia/diva/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/addressable-2.9"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/addressable/ s/2.8/2.9/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' -e '1irequire "json"' test/test_helper.rb || die
+}
diff --git a/dev-ruby/diva/diva-2.0.1.ebuild b/dev-ruby/diva/diva-2.0.1.ebuild
new file mode 100644
index 000000000000..e63936b904bd
--- /dev/null
+++ b/dev-ruby/diva/diva-2.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="diva.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of expression for handling things"
+HOMEPAGE="https://github.com/toshia/diva https://rubygems.org/gems/diva"
+SRC_URI="https://github.com/toshia/diva/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/addressable-2.9"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/addressable/ s/2.8/2.9/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' -e '1irequire "json"' test/test_helper.rb || die
+}
diff --git a/dev-ruby/diva/metadata.xml b/dev-ruby/diva/metadata.xml
index 3716f2a545c0..0ac8e7d4d47e 100644
--- a/dev-ruby/diva/metadata.xml
+++ b/dev-ruby/diva/metadata.xml
@@ -1,14 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>naota@gentoo.org</email>
+ <name>Naohiro Aota</name>
</maintainer>
<maintainer type="project">
<email>ruby@gentoo.org</email>
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
+ <remote-id type="github">toshia/diva</remote-id>
<remote-id type="rubygems">diva</remote-id>
</upstream>
</pkgmetadata>