summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/git/git-1.2.9.1-r1.ebuild')
-rw-r--r--dev-ruby/git/git-1.2.9.1-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/git/git-1.2.9.1-r1.ebuild b/dev-ruby/git/git-1.2.9.1-r1.ebuild
deleted file mode 100644
index 56d622a3de87..000000000000
--- a/dev-ruby/git/git-1.2.9.1-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
-
-RUBY_FAKEGEM_GEMSPEC="git.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Library for using Git in Ruby"
-HOMEPAGE="https://github.com/schacon/ruby-git"
-SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="ruby-git-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
-RDEPEND+=">=dev-vcs/git-1.6.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Needs test-unit, the test-unit version distributed with ruby19 is
- # not good enough.
- sed -i -e '3igem "test-unit"' Rakefile || die
-
- # Don't use hardcoded /tmp directory.
- sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
-}