summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/Manifest1
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild33
-rw-r--r--dev-ruby/gnuplot/metadata.xml5
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/gnuplot/Manifest b/dev-ruby/gnuplot/Manifest
new file mode 100644
index 000000000000..dd78bbea013a
--- /dev/null
+++ b/dev-ruby/gnuplot/Manifest
@@ -0,0 +1 @@
+DIST gnuplot-2.6.2.gem 13824 SHA256 d2c28d4a55867ef6f0a5725ce157581917b4d27417bc3767c7c643a828416bb3 SHA512 bcc9dbdade4fdcaa590006ca925c4f1eb71b4c7d6235c948266a185c937d991ff559a1749f33993baca4437252afdfa7bde1a43c6e05dc6f180e9e7b06a4a8e6 WHIRLPOOL 44bcdcc80e5c38e3e97afd9a9bf4e6d1d307fa8b42db3e2cd4b8aef7584ce9b389f8160f082efed7fc13457611ec28ea5cf42701e2880c8f7027291fe0d1035e
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
new file mode 100644
index 000000000000..1eb489943df4
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> not compatible since Config is removed
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND+=" sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm -f ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}
diff --git a/dev-ruby/gnuplot/metadata.xml b/dev-ruby/gnuplot/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/gnuplot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>