summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashery/hashery-2.1.1.ebuild')
-rw-r--r--dev-ruby/hashery/hashery-2.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/hashery/hashery-2.1.1.ebuild b/dev-ruby/hashery/hashery-2.1.1.ebuild
new file mode 100644
index 000000000000..e4a9873a0010
--- /dev/null
+++ b/dev-ruby/hashery/hashery-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Hashery is a tight collection of Hash-like classes"
+HOMEPAGE="http://rubyworks.github.com/hashery"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/lemon
+ dev-ruby/qed
+ dev-ruby/rubytest
+ dev-ruby/rubytest-cli )"
+
+each_ruby_test() {
+ ${RUBY} -S qed || die 'tests failed'
+ ${RUBY} -S rubytest -Ilib -Itest test/ || die 'tests failed'
+}