summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/memcache-client/memcache-client-1.8.5-r2.ebuild')
-rw-r--r--dev-ruby/memcache-client/memcache-client-1.8.5-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/memcache-client/memcache-client-1.8.5-r2.ebuild b/dev-ruby/memcache-client/memcache-client-1.8.5-r2.ebuild
new file mode 100644
index 000000000000..bb6160fdff51
--- /dev/null
+++ b/dev-ruby/memcache-client/memcache-client-1.8.5-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for accessing memcached"
+HOMEPAGE="http://github.com/mperham/memcache-client"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/flexmock )"
+
+all_ruby_prepare() {
+ # Remove tests that require a running memcache deamon.
+ rm test/test_benchmark.rb || die "Unable to remove performance tests."
+
+ # Fix silly JRuby test issue:
+ # https://github.com/mperham/memcache-client/issues/issue/14
+ sed -i -e '558s/e.message/e.message.downcase/' test/test_mem_cache.rb || die die "Could not fix JRuby issue."
+
+ # Fix rake deprecation.
+ sed -i -e 's:rake/rdoctask:rdoc/task:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -r test/unit test/test_mem_cache.rb || die "Tests failed."
+}