summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/method_source')
-rw-r--r--dev-ruby/method_source/Manifest1
-rw-r--r--dev-ruby/method_source/metadata.xml8
-rw-r--r--dev-ruby/method_source/method_source-0.8.2-r2.ebuild26
-rw-r--r--dev-ruby/method_source/method_source-0.8.2-r3.ebuild26
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/method_source/Manifest b/dev-ruby/method_source/Manifest
new file mode 100644
index 000000000000..913e74fce370
--- /dev/null
+++ b/dev-ruby/method_source/Manifest
@@ -0,0 +1 @@
+DIST method_source-0.8.2.gem 13312 SHA256 c2e9d0f4ebefd6b37efe38fe2964337b1d315fe198cad850681fd2da0027b1bc SHA512 44cf12bf0e47101f4e91b91b62c54e5403c827be5999b739a930e74c4449861a254631935f6a60430912316767fcc74e3f947075b0b0d994dc864bfdb935af1e WHIRLPOOL 126761dd7bff1a85693d98f28db31b1d7010f7ea4bbc05726ad9db9f80447ea135aa98ea004b0e4840856663c4afe0d35081c5e183d6473b7537b6e8daade8da
diff --git a/dev-ruby/method_source/metadata.xml b/dev-ruby/method_source/metadata.xml
new file mode 100644
index 000000000000..ad021576dea2
--- /dev/null
+++ b/dev-ruby/method_source/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">banister/method_source</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/method_source/method_source-0.8.2-r2.ebuild b/dev-ruby/method_source/method_source-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..074db3efb757
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}
diff --git a/dev-ruby/method_source/method_source-0.8.2-r3.ebuild b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
new file mode 100644
index 000000000000..21a313d35dec
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="https://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}