summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-ssh')
-rw-r--r--dev-ruby/net-ssh/Manifest5
-rw-r--r--dev-ruby/net-ssh/metadata.xml24
-rw-r--r--dev-ruby/net-ssh/net-ssh-4.2.0.ebuild37
-rw-r--r--dev-ruby/net-ssh/net-ssh-7.1.0.ebuild (renamed from dev-ruby/net-ssh/net-ssh-5.2.0.ebuild)21
-rw-r--r--dev-ruby/net-ssh/net-ssh-7.2.1.ebuild50
-rw-r--r--dev-ruby/net-ssh/net-ssh-7.2.3.ebuild50
6 files changed, 129 insertions, 58 deletions
diff --git a/dev-ruby/net-ssh/Manifest b/dev-ruby/net-ssh/Manifest
index dabb11af31f0..8ae33fd07332 100644
--- a/dev-ruby/net-ssh/Manifest
+++ b/dev-ruby/net-ssh/Manifest
@@ -1,2 +1,3 @@
-DIST net-ssh-git-4.2.0.tgz 197417 BLAKE2B 5714185d9b83d3010e6b9baa07ac541e9227379cbfecc3a506d870d8d9fa528f59b605df4ff02ae6bfc16893bfb22734395096a77fcbe19fb939ecc1a343a9b5 SHA512 0a3609590d797a8cb4732e8cf743606a4919f57475b6eb2447a3db0c28f1bd405804fdc47a4062e503acdd4b785a1de9794a6db433cabb884105166eff6a8c5b
-DIST net-ssh-git-5.2.0.tgz 209986 BLAKE2B 6a1bc97da733420607c6ebe69a01f42d58998297a12394a29c9b4f5af425781d6b1b3535cecef21a0918eefc2e032f519fce9c5691c0a735c7810452f468d780 SHA512 cf2fa9817b124f0f35115abef51a4865073b3126b94d66cd307994bba06745513aaab1c1bcf64907a7b3bbce793b272b3f521cfa93f9339ca78ec8cef09cbeeb
+DIST net-ssh-git-7.1.0.tgz 229217 BLAKE2B ab3c46d3d8831335495ae72dc60f2659109b66566f04117a16e4fd41085203b6a2d333e65ffcda4e390c96a2b808c68baeb168be1a2e23d4c797ad63b5af93f9 SHA512 723f487e77526a7acba8a9c8f09dd85c8c0bb21577d148f6c4280c79d603d3d364e29fb55b2b282064b5c108465efb2b1da061a2ba5872d575b0be264f493745
+DIST net-ssh-git-7.2.1.tgz 233338 BLAKE2B 14696b3c5de24219b0e5d5ad345aa46a1576183f4836ccdaf1d5feb78cb932232da1890c55d8c39dbf1d47b1fc0c19acf53eedd1f87bf8acb0d62ae10045e828 SHA512 9b13c33ed76a9ac346c610e8eb04fba5b327c9f79d2a28ca7d2c9b6fa94d3979f68b43f3fd2b83eb2ea0e3ada5e200373848b5f7abdee7922d77aa30d148b88b
+DIST net-ssh-git-7.2.3.tgz 233375 BLAKE2B d8eda3964b66e7a7c55f70a1ba763bacf192edcb6f32f679d36b4c589c6184af9911db6db4cb28e273a27ac4bd68afc4b0a0767d98955b2e37bcd65444c77d8a SHA512 621eb0c8080347614e924c236646cadaaceefb0894a818dc60cebc7c09c87d6ae6117f33628ed48fa8598fdb74146c9d2f114b178bd119908df8396103ceb4d9
diff --git a/dev-ruby/net-ssh/metadata.xml b/dev-ruby/net-ssh/metadata.xml
index b6f4d7853048..bc9c39fc40f7 100644
--- a/dev-ruby/net-ssh/metadata.xml
+++ b/dev-ruby/net-ssh/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">net-ssh/net-ssh</remote-id>
- </upstream>
- <use>
- <flag name="ed25519">Use <pkg>dev-ruby/ed25519</pkg> for Ed25519 support</flag>
- <flag name="sodium">Use <pkg>dev-libs/libsodium</pkg> via <pkg>dev-ruby/rbnacl</pkg> for Ed25519 support</flag>
- </use>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">net-ssh/net-ssh</remote-id>
+ </upstream>
+ <use>
+ <flag name="chacha20">Use <pkg>dev-ruby/rbnacl</pkg> for chacha20-poly1305@openssh.com support</flag>
+ <flag name="ed25519">Use <pkg>dev-ruby/ed25519</pkg> for Ed25519 support</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
deleted file mode 100644
index a1cd8e45c46a..000000000000
--- a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
-RUBY_FAKEGEM_EXTRAINSTALL="support"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Non-interactive SSH processing in pure Ruby"
-HOMEPAGE="https://github.com/net-ssh/net-ssh"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="sodium test"
-
-ruby_add_rdepend "virtual/ruby-ssl sodium? ( dev-ruby/rbnacl:4 dev-ruby/bcrypt_pbkdf )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
-
-all_ruby_prepare() {
- # Don't use a ruby-bundled version of libsodium
- sed -i -e '/rbnacl\/libsodium/ s:^:#:' lib/net/ssh/authentication/ed25519.rb || die
-
- # Don' try to use libsodium-related tests with USE=-sodium
- if ! use sodium ; then
- rm -f test/authentication/test_ed25519.rb
- fi
-
- # Avoid bundler dependency
- sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
-}
diff --git a/dev-ruby/net-ssh/net-ssh-5.2.0.ebuild b/dev-ruby/net-ssh/net-ssh-7.1.0.ebuild
index 35a8a5189f03..d5c87deb7de9 100644
--- a/dev-ruby/net-ssh/net-ssh-5.2.0.ebuild
+++ b/dev-ruby/net-ssh/net-ssh-7.1.0.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.md THANKS.txt"
RUBY_FAKEGEM_EXTRAINSTALL="support"
+RUBY_FAKEGEM_GEMSPEC="net-ssh.gemspec"
+
inherit ruby-fakegem
DESCRIPTION="Non-interactive SSH processing in pure Ruby"
@@ -16,16 +18,21 @@ HOMEPAGE="https://github.com/net-ssh/net-ssh"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
LICENSE="GPL-2"
-SLOT="5"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
+SLOT="$(ver_cut 1)"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
IUSE="ed25519 test"
+RESTRICT="!test? ( test )"
-ruby_add_rdepend "virtual/ruby-ssl ed25519? ( dev-ruby/ed25519 dev-ruby/bcrypt_pbkdf )"
+ruby_add_rdepend "virtual/ruby-ssl ed25519? ( >=dev-ruby/ed25519-1.2:1 dev-ruby/x25519 dev-ruby/bcrypt_pbkdf:1 )"
ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
all_ruby_prepare() {
# Avoid bundler dependency
sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
+
+ sed -e "s:require_relative ':require './:" \
+ -e 's/git ls-files -z/find -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
}
src_test() {
diff --git a/dev-ruby/net-ssh/net-ssh-7.2.1.ebuild b/dev-ruby/net-ssh/net-ssh-7.2.1.ebuild
new file mode 100644
index 000000000000..dd43d42338d9
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-7.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.md THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+RUBY_FAKEGEM_GEMSPEC="net-ssh.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-ssh"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="chacha20 ed25519 test"
+RESTRICT="!test? ( test )"
+
+ruby_add_rdepend "
+ virtual/ruby-ssl
+ chacha20? ( dev-ruby/rbnacl )
+ ed25519? ( >=dev-ruby/ed25519-1.2:1 dev-ruby/x25519 dev-ruby/bcrypt_pbkdf:1 )
+"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+all_ruby_prepare() {
+ # Avoid bundler dependency
+ sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
+
+ sed -e "s:require_relative ':require './:" \
+ -e 's/git ls-files -z/find -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+src_test() {
+ # prevent tests from trying to connect to ssh-agent socket and failing
+ unset SSH_AUTH_SOCK
+ if ! use ed25519; then
+ export NET_SSH_NO_ED25519=true
+ fi
+ ruby-ng_src_test
+}
diff --git a/dev-ruby/net-ssh/net-ssh-7.2.3.ebuild b/dev-ruby/net-ssh/net-ssh-7.2.3.ebuild
new file mode 100644
index 000000000000..3d9b5e520a7c
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-7.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.md THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+RUBY_FAKEGEM_GEMSPEC="net-ssh.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-ssh"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="chacha20 ed25519 test"
+RESTRICT="!test? ( test )"
+
+ruby_add_rdepend "
+ virtual/ruby-ssl
+ chacha20? ( dev-ruby/rbnacl )
+ ed25519? ( >=dev-ruby/ed25519-1.2:1 dev-ruby/x25519 dev-ruby/bcrypt_pbkdf:1 )
+"
+
+ruby_add_bdepend "test? ( dev-ruby/base64 dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+all_ruby_prepare() {
+ # Avoid bundler dependency
+ sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
+
+ sed -e "s:require_relative ':require './:" \
+ -e 's/git ls-files -z/find -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+src_test() {
+ # prevent tests from trying to connect to ssh-agent socket and failing
+ unset SSH_AUTH_SOCK
+ if ! use ed25519; then
+ export NET_SSH_NO_ED25519=true
+ fi
+ ruby-ng_src_test
+}