summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth2/oauth2-1.0.0.ebuild')
-rw-r--r--dev-ruby/oauth2/oauth2-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/oauth2-1.0.0.ebuild b/dev-ruby/oauth2/oauth2-1.0.0.ebuild
new file mode 100644
index 000000000000..863f66f36290
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem"
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}