summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/oauth-0.5.4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.4.ebuild b/dev-ruby/oauth/oauth-0.5.4.ebuild
index d674b5571b49..59a71726716a 100644
--- a/dev-ruby/oauth/oauth-0.5.4.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,16 +21,19 @@ KEYWORDS="~amd64 ~ppc ~x86 ~x86-macos"
IUSE=""
ruby_add_bdepend "test? (
+ dev-ruby/bundler
dev-ruby/test-unit:2
dev-ruby/mocha:1.0
dev-ruby/webmock
dev-ruby/rack
dev-ruby/actionpack:5.2
+ dev-ruby/railties:5.2
)"
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.2.0"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>5.2.0" ; gem "actionpack", "~>5.2.0"' \
-e '2i gem "test-unit"; require "test/unit"' \
+ -e '/mocha/ s/mini_test/minitest/' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
}